Unable to add my Checkpoint Appliances to Indeni

Unable to add my Checkpoint Appliances to Indeni
0

Hi All,
I am working on adding my Checkpoint Appliances (Both Gateway and Smart Center Server) on to the Indeni, But for some reason I am not able to. When I look at the error logs and I see that its detecting as a Juniper/ Palo Alto appliance. I have pasted the screen shots of the error messages below for reference. Can any one help me with this...!!

Thanks in advance.
Image title


Image title









Thanks for updating us with this information. I was hoping you could provide some details arounds the login. Are you connecting to the devices over HTTPS or SSH? If SSH, then let's uncheck HTTPS, and let me know if you continue to have the issue.


Best,

note that Nikhil is getting the same "junos-show-version-interrogation" error that I'm seeing... (https://community.indeni.com/discussions/topics/37437?page=1)

- I wanted to elaborate on how to send the logs.


From the VM, or your CLI, log into the the Indeni server. Type in 'imanage', then choose option [8].

Nikhil,


While I review the logs, I was wondering if you could try adding the subnet the devices are on, and let me know if you get the same results. Much Thanks!


Image title


Yes Paul, I have added the subnet and tried it over. Yet I still see the same error.

Today guided me through a workaround to the 'junos-show-version-interrogation' error (thank you Dimitris!). It's not a fix, but it did allow me to add my Cisco device and move forward. The workaround was to drop his cisco_ios_show_version.ind script into /usr/share/indeni-collector/kb/parsers/cisco/ios (we added the /cisco/ios) and restart the collector. This (somehow) short-circuited the junos interrogation failure and allowed indeni to add the device.


As we talked it through, the best guess as to the cause of the junos-show-version-interrogation failure was that it was expecting an XML response from the Cisco router, but receiving text, and then erroring out, hence the "Failed to parse XML" error message. I haven't yet tried to run this script in isolation, but I will, hopefully tomorrow -- at least for my own learning. I'm sortof guessing that someone has already fixed this issue in a more recent version of the script -- otherwise it feels like more people should be running into this error? I'll try to find out.



- where you able to resolve your issues? I hijacked your thread -- sorry about that. I was able to resolve the issue on my server, as noted below. Feel free to PM me if you're still having trouble and think I can help.