Error interrogating Cisco 7200 - junos-show-version-interrogation Parse Error

Error interrogating Cisco 7200 - junos-show-version-interrogation Parse Error
0

This is my first time trying to add a device to Indeni. The Indeni server is a local VM; I've updated everything and restarted.


- Trying to add a Cisco 7200 router

- This a virtualized device on a local (to this host), virtual network

- I can ssh into the device from the host, can ping the device from Indeni server

- some relevant router config (full config: 7200config.txt):

username sshuser password 0 Changeme1

ip ssh version 2
no ip http server

no ip http secure-server
line vty 0 4

login local
transport input ssh

- my Indeni credential set has a single SSH entry using the above sshuer/Changeme1


Error (screenshot below):

Interrogation failed Details: junos-show-version-interrogation: Header = Parse Error, Description = Command [192.168.204.132] junos-show-version-interrogation parser failed with input: ^ % Invalid input detected at '^' marker. , Message = Header = Execution Error, Description = Failed to parse XML, Message = Content is not allowed in prolog., , https-interrogation: Header = Execution Error, Description = Executor No appropriate client found for operation HttpInterrogationOperation(https), command: https-interrogation did not execute,


I can understand the message about https-interrogation (is that a critical error? do I need to enable HTTP access on the router?), but I don't understand what to do about the junos-show-version-interrogation Parse Error.


I can certainly debug into this more on my own, but any help would be welcome.


-hawkeye


Image title



Thanks for the update, Hawkeye. I was curious about the following:


1. What kind of Credential Set did you create? Do you have HTTP checked as well? If so, and you're trying to connect via SSH, uncheck the HTTPS option.


2. Do you have an outside internet access to the local machine and GNS3? When I setup a virtual 7200 IOS, having a valid outside connection helped the Indeni server connect a router via GNS3.


Let us know how it goes, especially after checking #1.

#2 was more of a curiosity for me, but wondering if that could be a possible culrpit here.


Best,

Thanks Paul. Credential set is SSH only, no HTTP. I'm assuming that's enough for the scripts that would run agains this router, but I don't really know.


The VM host (my desktop) has internet access, and the Indeni server VM has NAT access through eth1 (I added that). Indeni's eth0, the GNS3 VM and virtual router are all on VMWare's "host-only" network, aka VMnet1 -- so nothing in GNS3 has internet access. As long as the indeni server is just trying to ssh into the router, this should all be fine -- I can manually ssh into the router from the indeni server cli.


One obvious question is why a junos interrogation script is trying to run against an IOS router.... If someone can't hold my hand through this, I'll try to manually run a script agains the router tomorrow -- I guess using script runner. Baby steps :)



This thread has collapsed into this one for now: https://community.indeni.com/discussions/topics/37458?page=1

Workaround here (posted by me): https://community.indeni.com/discussions/topics/37458?page=1