Configuring Timeout Values for Administrative Web Sessions

Configuring Timeout Values for Administrative Web Sessions
0

#1

How do you configure the timeout for an admin that logins to the webGUI?
I can set the CLI timeout window using “set cli idle-timeout”, but I can’t find one for the WebGUI. I found this article: http://live.paloaltonetworks.com/t5/Management-Articles/Short-TCP-Session-Timeout-Causes-GUI-and-SSH-Failure/ta-p/54386

But this encompasses all TCP sessions.


#2

From CLI enter: " set deviceconfig setting management idle-timeout ", the default is 60 minutes, changing it to 0 will result in never timing out.


#3

Same can be accomplished from GUI at “Device > Setup > Management > Authentication Settings”


#4

Was just going to post this: https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA10g000000CltDCAS :slight_smile:


#5

Hm…why does it ask to run “show cli idle timeout” to validate that it worked though?


#6

The link you quoted deals with the actual session at the TCP layer not the application/management GUI/CLI layer. The idle timeout is for the CLI and GUI. It isn’t even at SSH and HTTPS necessarily. This timeout setting is for Management specifically therefore both CLI based and GUI based so the CLI based method to check the setting would the the “show cli idle timeout” whereas the GUI method of checking is the screenshot shown in the link I posted.