Command-runner doing nothing

Command-runner doing nothing
0

Hi Community,
I am sure I am missing something really silly here, but it seems I cannot have command-runner doing anything useful, it just says, compiling, exiting, and I have no output. Tried with parse-only and connecting to a live F5 device, same thing. I am testing with a already existing IND script (f5 matchclass), can someone point what I am missing out here? thanks in advance!. Logs below:

~indeni-knowledge/parsers/src/f5/ltm/tmsh-list-ltm-rule-recursive$ command-runner full-command tmsh-list-ltm-rule-recursive.ind.yaml 172.16.61.101 --ssh indeni,somepasswd
2019-07-07 15:20:15,445 INFO – Starting command runner
2019-07-07 15:20:15,447 INFO – About to run full-command on device ‘172.16.61.101’ with source ‘Set(tmsh-list-ltm-rule-recursive.ind.yaml)’
2019-07-07 15:20:15,448 INFO – Credentials: Set(SshUsernamePasswordCredentials(None,indeni,somepasswd,None,false))
2019-07-07 15:20:15,839 INFO – Compiling ‘tmsh-list-ltm-rule-recursive.ind.yaml’
2019-07-07 15:20:15,847 INFO – Exiting

~indeni-knowledge/parsers/src/f5/ltm/tmsh-list-ltm-rule-recursive$ command-runner parse-only tmsh-list-ltm-rule-recursive.ind.yaml -f input_rule.input
2019-07-07 15:20:32,336 INFO – Starting command runner
2019-07-07 15:20:32,701 INFO – About to run parse-only on ‘tmsh-list-ltm-rule-recursive.ind.yaml’ with input from ‘input_rule.input’
2019-07-07 15:20:32,702 INFO – Reading input from input_rule.input
2019-07-07 15:20:32,710 INFO – Compiling ‘tmsh-list-ltm-rule-recursive.ind.yaml’
2019-07-07 15:20:32,714 INFO – Exiting

~indeni-knowledge/parsers/src/f5/ltm/tmsh-list-ltm-rule-recursive$ cat input_rule.input
ltm rule matchrule {
when HTTP_REQUEST {
if { [matchclass [HTTP::uri] starts_with redirectURIs] } {
HTTP::redirect “http://www.domain.com/unavailable.html
}
}
}

~indeni-knowledge/parsers/src/f5/ltm/tmsh-list-ltm-rule-recursive$ java --version
java 11.0.3 2019-04-16 LTS
Java™ SE Runtime Environment 18.9 (build 11.0.3+12-LTS)
Java HotSpot™ 64-Bit Server VM 18.9 (build 11.0.3+12-LTS, mixed mode)

~indeni-knowledge/parsers/src/f5/ltm/tmsh-list-ltm-rule-recursive$ uname -a
Linux box 4.15.0-20-generic #21-Ubuntu SMP Tue Apr 24 06:16:15 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

~indeni-knowledge/parsers/src/f5/ltm/tmsh-list-ltm-rule-recursive$ cat /etc/os-release
NAME=“Ubuntu”
VERSION=“18.04 LTS (Bionic Beaver)”

Not missing anything silly. It’s a known bug. Just cd up a directory, and reference the .ind.yaml file using a relative path.

… full-command ./parent_dir/my script.ind.yaml

HTH!

1 Like

Thanks @Hawkeye_Parker! Spot on! I moved up a directory and it works now. Thanks for your help

Best Regards,
Oscar

1 Like